Для программирования подходит комп от 1 пентиума до последнего и ОС от WIN 98 до XP. Нужна версия софта от 2 и выше.